Undefined variable

5 posts / 0 new
Last post
sigurdur
sigurdur's picture
Undefined variable

Hi again,

An error has started popping up on Home-Variant-8:

Undefined variable: img in include() (line 47 of /srv/www/ninukot.is/public_html/sites/all/themes/ebazar/templates/views-view-field--categories--tid.tpl.php

Any thoughts as to how I might start troubleshooting this?

Best regards,
Sigurdur

support
support's picture
Hi Sigudur:

Hi Sigudur:

Any chance to check your site??? Try this:

1 - Go to Admin -> Configuration -> Search API -> Edit the Products Index
2 - Then go to the Tab View and "Clear all indexed data".

Best!!!

support
support's picture
And then re-index again!!!

And then re-index again!!!

Sorry!!!

sigurdur
sigurdur's picture
This didn't work. The URL is

This didn't work. The URL is test.ninukot.is and you can see the error on the front page. The site is under heavy development and I'm mucking around with the code a bit. Is this indexing related or should I be looking elsewhere as well?

sigurdur
sigurdur's picture
OK, think I know what is

OK, think I know what is going on. I'm adjusting the taxonomy vocabularies and in a fit of madness I changed the machine names in order to fit the new names and structure of the site. I thought I had fixed that everywhere needed, i.e. views etc. but I see the old machine names are being referenced in the Product Index. Guess I should have heeded the warnings of not playing with the machine names. It's just irritating having the machine name "Gender" referring to the vocabulary "Continent" :)

Log in to post comments