Install DOES NOT work

10 posts / 0 new
Last post
adon
adon's picture
Install DOES NOT work

EDIT:
Install was broken due to permissions. 755/644 only works if owner is also www-data, which is not the case on my server.

For others, this was my simple fix:
in sites/default/files
find . -type d -print -exec chmod 775 {} \;
find . -type f -print -exec chmod 664 {} \;

regards,
Adon

support
support's picture
Hi Adon:

Hi Adon:

Thanks for sharing!!! Could you please share your server setup info so others can compare?

99% of times, the install goes fine.

Best!!

adon
adon's picture
Server config

Sure.. .
I'm running LAMP.
Debian Linux 6.0
Apache 2.2.16 (Debian) - built: Feb 1 2014 21:22:42
MySQL Ver 14.14 Distrib 5.1.73, for debian-linux-gnu (x86_64) using readline 6.1
PHP 5.3.3-7+squeeze19 with Suhosin-Patch (cli) (built: Feb 17 2014 10:10:23)

Happy to answer any other questions if would be helpful..

oh, and the permissions on the .sql dump were also user based but not group based (so this was the root problem, having apache run as www-data not as the user owner of the files)

Regards,
Adon

support
support's picture
Hi Adon: Thanks!!!!

Hi Adon:

Thanks!!!!

adon
adon's picture
Additional problem.

The .zip file (3v30) appears to be riddled with hidden files, .DS_Store
Not removing them breaks the module update process, and really breaks the site.

This is what I had to do to fix (from root of drupal install):
find . -type f -iname ".DS_Store" -print -exec rm {} \;

[quite sure i simply uploaded the .zip as provided, and extracted on my linux server. so these wouldn't have been generated by me, hence i believe they are in the zip you are distributing]

adon
adon's picture
Additional issue

socialmedia module, upon update, causes this:
The requested URL "/sites/all/modules/socialmedia/icons/icondock/Vector%20Social%20Media%20Icons/png/24px/delicious.png" was not found on this server.

I can manually re-copy these files, but a bit ugly to have to manually fix after every module update.
Not exactly great for production ready environment.

And strangely your .zip has PNG as folder name, but theme files expect png. Perhaps upgraded socialmedia module alters this.

Just an FYI for others' benefit.

Adon

adon
adon's picture
Webform is not *recommended* version

Theme uses v4 of Webform (not the recommended, production ready one).
It is buggy.

https://www.drupal.org/node/2315339

Updating this module will cause a break. Not exactly a theme issue, but certainly relevant if it breaks the update process.

support
support's picture
Hi Adon: Thanks for sharing!!

Hi Adon:

Thanks for sharing!!

adon
adon's picture
rc6 of webform resolves issue

Version Download Date Links
7.x-4.0-rc6 tar.gz (188.32 KB) | zip (231.51 KB) 2014-Aug-19

This Aug 19th release resolves the issue.

support
support's picture
Hi Adon:

Hi Adon:

Testing right away! Thanks for letting us know.

Best!

Log in to post comments