DO NOT USE Database prefixes - you're loading an Installation Profile

4 posts / 0 new
Last post
support
support's picture
DO NOT USE Database prefixes - you're loading an Installation Profile

I have got these errors :

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'factueldrupal.fact_actions' doesn't exist

Uncaught exception thrown in shutdown function.

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'factueldrupal.fact_semaphore' doesn't exist:
DELETE FROM {semaphore} WHERE (value = :db_condition_placeholder_0) ; Array ( [:db_condition_placeholder_0] =>
7637465715037739ac9e411.53073676 ) in lock_release_all() (line 269 of / homez.338/factuel/www/drupal-v4/includes/lock.inc).
Uncaught exception thrown in session handler.

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'factueldrupal.fact_sessions' doesn't exist:
SELECT 1 AS expression FROM {sessions} sessions WHERE ( (sid = :db_condition_placeholder_0) AND (ssid = :db_condition_placeholder_1) ) FOR UPDATE; Array ( [:db_condition_placeholder_0] => SC8sKXliq4Wx8QygMAwffPkcaWKFBBkll4Dwg_evSjQ
[:db_condition_placeholder_1] => ) in _drupal_session_write() (line
209 of /homez.338/factuel/www/drupal-v4/includes/session.inc).

support
support's picture
Not a problem, just follow

Not a problem, just follow these steps:

1. Open the file /sites/default/settings.php

2. On line 214, set no prefix with'prefix' => '',

nick.e
nick.e's picture
Don't think that's it

On install - we don't enter anything into the prefix.
Nonetheless I checked and here are the relevant lines of the settings.php file

184 array (
185 'database' => 'WhiteheadSigns',
186 'username' => 'Whitehead_USR',
187 'password' => '******',
188 'host' => 'localhost',
189 'port' => '',
190 'driver' => 'mysql',
191 'prefix' => '',
192 ),

As you can see, the prefix is already empty. Any other ideas?

Thank you for your time.

support
support's picture
Hi there Nick:

Hi there Nick:

Seems the profile fix wasn´t updated. I´ve just sent you via mail the correct backup and I´m updating it on the downloadable package.

Best!

Log in to post comments